CVE-2018-6514

NameCVE-2018-6514
DescriptionIn Puppet Agent 1.10.x prior to 1.10.13, Puppet Agent 5.3.x prior to 5.3.7, Puppet Agent 5.5.x prior to 5.5.2, Facter on Windows is vulnerable to a DLL preloading attack, which could lead to a privilege escalation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
facter (PTS)stretch2.4.6-1fixed
buster3.11.0-2+deb10u2fixed
bullseye, sid3.14.12-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
factersource(unstable)(not affected)

Notes

- facter <not-affected> (Specific to Facter on Windows)
https://puppet.com/security/cve/CVE-2018-6514

Search for package or bug name: Reporting problems