CVE-2018-6519

NameCVE-2018-6519
DescriptionThe SAML2 library before 1.10.4, 2.x before 2.3.5, and 3.x before 3.1.1 in SimpleSAMLphp has a Regular Expression Denial of Service vulnerability for fraction-of-seconds data in a timestamp.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4127-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
simplesamlphp (PTS)jessie1.13.1-2+deb8u1fixed
jessie (security)1.13.1-2+deb8u2fixed
stretch (security), stretch1.14.11-1+deb9u1fixed
buster1.16.3-1fixed
sid1.17.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
simplesamlphpsource(unstable)1.15.2-1medium
simplesamlphpsourcejessie1.13.1-2+deb8u1mediumDSA-4127-1
simplesamlphpsourcestretch1.14.11-1+deb9u1mediumDSA-4127-1
simplesamlphpsourcewheezy(not affected)

Notes

[wheezy] - simplesamlphp <not-affected> (Vulnerable code not present)
minor issue
https://simplesamlphp.org/security/201801-01
The issue lies in the simplesamlphp/saml2 part, which is
updated in 1.15.2 to the respective fixed version.
https://github.com/simplesamlphp/saml2/commit/726404bf7b4085a9eb9c9a869af1ecc146bd8f6d

Search for package or bug name: Reporting problems