CVE-2018-6521

NameCVE-2018-6521
DescriptionThe sqlauth module in SimpleSAMLphp before 1.15.2 relies on the MySQL utf8 charset, which truncates queries upon encountering four-byte characters. There might be a scenario in which this allows remote attackers to bypass intended access restrictions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1273-1, DSA-4127-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
simplesamlphp (PTS)jessie1.13.1-2+deb8u1fixed
jessie (security)1.13.1-2+deb8u2fixed
stretch (security), stretch1.14.11-1+deb9u1fixed
buster, sid1.16.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
simplesamlphpsource(unstable)1.15.2-1high
simplesamlphpsourcejessie1.13.1-2+deb8u1highDSA-4127-1
simplesamlphpsourcestretch1.14.11-1+deb9u1highDSA-4127-1
simplesamlphpsourcewheezy1.9.2-1+deb7u2highDLA-1273-1

Notes

https://simplesamlphp.org/security/201801-03

Search for package or bug name: Reporting problems