CVE-2018-6574

NameCVE-2018-6574
DescriptionGo before 1.8.7, Go 1.9.x before 1.9.4, and Go 1.10 pre-releases before Go 1.10rc2 allow "go get" remote command execution during source code build, by leveraging the gcc or clang plugin feature, because -fplugin= and -plugin= arguments were not blocked.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4380-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
golang-1.7 (PTS)stretch1.7.4-2+deb9u1vulnerable
stretch (security)1.7.4-2+deb9u3vulnerable
golang-1.8 (PTS)stretch1.8.1-1+deb9u1fixed
stretch (security)1.8.1-1+deb9u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
golangsource(unstable)(unfixed)
golang-1.10source(unstable)1.10~rc2-1
golang-1.7source(unstable)(unfixed)
golang-1.8sourcestretch1.8.1-1+deb9u1DSA-4380-1
golang-1.8source(unstable)(unfixed)
golang-1.9source(unstable)1.9.4-1

Notes

[stretch] - golang-1.7 <ignored> (Minor issue, may break packages compilation, ignored for 1.7 by package maintainers)
[jessie] - golang <ignored> (Minor issue)
[wheezy] - golang <ignored> (Minor issue)
https://github.com/golang/go/issues/23672
https://go.googlesource.com/go/+/44821583bc16ff2508664fab94360bb856e9e9d6 (1.8.x)
https://go.googlesource.com/go/+/867fb18b6d5bc73266b68c9a695558a04e060a8a (1.9.x)
https://github.com/golang/go/issues/23749 (regressions)

Search for package or bug name: Reporting problems