CVE-2018-6596

NameCVE-2018-6596
Descriptionwebhooks/base.py in Anymail (aka django-anymail) before 1.2.1 is prone to a timing attack vulnerability on the WEBHOOK_AUTHORIZATION secret, which allows remote attackers to post arbitrary e-mail tracking events.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4107-1
NVD severitymedium (attack range: remote)
Debian Bugs889450

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
django-anymail (PTS)stretch/contrib (security), stretch/contrib0.8-2+deb9u1fixed
sid/contrib, buster/contrib3.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
django-anymailsource(unstable)1.3-1medium889450
django-anymailsourcestretch0.8-2+deb9u1mediumDSA-4107-1

Notes

https://github.com/anymail/django-anymail/commit/db586ede1fbb41dce21310ea28ae15a1cf1286c5 (v1.3)
https://github.com/anymail/django-anymail/commit/c07998304b4a31df4c61deddcb03d3607a04691b (v1.2.x-branch)

Search for package or bug name: Reporting problems