CVE-2018-6611

NameCVE-2018-6611
Descriptionsoundlib/Load_stp.cpp in OpenMPT through 1.27.04.00, and libopenmpt before 0.3.6, has an out-of-bounds read via a malformed STP file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs889545

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libopenmpt (PTS)stretch0.2.7386~beta20.3-3+deb9u3fixed
stretch (security)0.2.7386~beta20.3-3+deb9u4fixed
buster, buster (security)0.4.3-1+deb10u1fixed
bullseye, sid0.4.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libopenmptsourcestretch(not affected)
libopenmptsource(unstable)0.3.6-1889545

Notes

[stretch] - libopenmpt <not-affected> (Vulnerable code not present)
https://github.com/OpenMPT/openmpt/commit/61fc6d3030a4d4283105cb5fb46b27b42fa5575e

Search for package or bug name: Reporting problems