CVE-2018-6758

NameCVE-2018-6758
DescriptionThe uwsgi_expand_path function in core/utils.c in Unbit uWSGI through 2.0.15 has a stack-based buffer overflow via a large directory length.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1275-1
NVD severityhigh (attack range: remote)
Debian Bugs889753

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
uwsgi (PTS)jessie (security), jessie2.0.7-1+deb8u2fixed
stretch (security), stretch2.0.14+20161117-3+deb9u2fixed
buster2.0.18-1fixed
bullseye, sid2.0.18-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
uwsgisource(unstable)2.0.15-10.2high889753
uwsgisourcejessie2.0.7-1+deb8u2high
uwsgisourcestretch2.0.14+20161117-3+deb9u1high
uwsgisourcewheezy1.2.3+dfsg-5+deb7u2highDLA-1275-1

Notes

http://lists.unbit.it/pipermail/uwsgi/2018-February/008835.html
https://github.com/unbit/uwsgi/commit/cb4636f7c0af2e97a4eef7a3cdcbd85a71247bfe

Search for package or bug name: Reporting problems