CVE-2018-6767

NameCVE-2018-6767
DescriptionA stack-based buffer over-read in the ParseRiffHeaderConfig function of cli/riff.c file of WavPack 5.1.0 allows a remote attacker to cause a denial-of-service attack or possibly have unspecified other impact via a maliciously crafted RF64 file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs889276

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wavpack (PTS)wheezy4.60.1-3fixed
jessie4.70.0-1fixed
stretch5.0.0-2vulnerable
buster, sid5.1.0-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wavpacksource(unstable)(unfixed)889276
wavpacksourcejessie(not affected)
wavpacksourcewheezy(not affected)

Notes

[jessie] - wavpack <not-affected> (Vulnerable code introduced later in 4.80.0)
[wheezy] - wavpack <not-affected> (Vulnerable code introduced later in 4.80.0)
https://github.com/dbry/WavPack/issues/27
https://github.com/dbry/WavPack/commit/d5bf76b5a88d044a1be1d5656698e3ba737167e5

Search for package or bug name: Reporting problems