CVE-2018-6797

NameCVE-2018-6797
DescriptionAn issue was discovered in Perl 5.18 through 5.26. A crafted regular expression can cause a heap-based buffer overflow, with control over the bytes written.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
perl (PTS)jessie (security), jessie5.20.2-3+deb8u11vulnerable
stretch (security), stretch5.24.1-3+deb9u4fixed
buster, sid5.26.2-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
perlsource(unstable)5.26.1-6high
perlsourcestretch5.24.1-3+deb9u3high

Notes

[jessie] - perl <ignored> (Backport of fixes too intrusive and risky for regressions)
[wheezy] - perl <ignored> (Backport of fixes too intrusive and risky for regressions)
https://rt.perl.org/Public/Bug/Display.html?id=132227
maint-5.26: https://perl5.git.perl.org/perl.git/commitdiff/abe1e6c568b96bcb382dfa4f61c56d1ab001ea51
maint-5.24: https://perl5.git.perl.org/perl.git/commitdiff/510cc261d965ccfa427900ebb368fc4d337442d2

Search for package or bug name: Reporting problems