CVE-2018-6798

NameCVE-2018-6798
DescriptionAn issue was discovered in Perl 5.22 through 5.26. Matching a crafted locale dependent regular expression can cause a heap-based buffer over-read and potentially information disclosure.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
perl (PTS)jessie5.20.2-3+deb8u11fixed
jessie (security)5.20.2-3+deb8u12fixed
stretch5.24.1-3+deb9u4fixed
stretch (security)5.24.1-3+deb9u5fixed
buster5.28.1-1fixed
sid5.28.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
perlsource(unstable)5.26.1-6medium
perlsourcejessie(not affected)
perlsourcestretch5.24.1-3+deb9u3medium
perlsourcewheezy(not affected)

Notes

[jessie] - perl <not-affected> (Issue introduced later)
[wheezy] - perl <not-affected> (Issue introduced later)
https://rt.perl.org/Public/Bug/Display.html?id=132063
maint-5.26: https://perl5.git.perl.org/perl.git/commitdiff/8e6f44c90c7fa1f63c19a44c45482b09a407e15b
maint-5.26: https://perl5.git.perl.org/perl.git/commitdiff/8b80ce67ff257aaa36e47eaf4194d27a51595524
maint-5.24: https://perl5.git.perl.org/perl.git/commitdiff/0abf1e8d89aecd32dbdabda5da4d52a2d57a7cff
maint-5.24: https://perl5.git.perl.org/perl.git/commitdiff/f65da1ca2eee74696d9c120e9d69af37b4fa1920

Search for package or bug name: Reporting problems