CVE-2018-7254

NameCVE-2018-7254
DescriptionThe ParseCaffHeaderConfig function of the cli/caff.c file of WavPack 5.1.0 allows a remote attacker to cause a denial-of-service (global buffer over-read), or possibly trigger a buffer overflow or incorrect memory allocation, via a maliciously crafted CAF file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4125-1
NVD severitymedium (attack range: remote)
Debian Bugs889274

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wavpack (PTS)jessie4.70.0-1fixed
stretch (security), stretch5.0.0-2+deb9u2fixed
buster, sid5.1.0-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wavpacksource(unstable)5.1.0-3medium889274
wavpacksourcejessie(not affected)
wavpacksourcestretch5.0.0-2+deb9u1mediumDSA-4125-1
wavpacksourcewheezy(not affected)

Notes

[jessie] - wavpack <not-affected> (Vulnerable code not present)
[wheezy] - wavpack <not-affected> (Vulnerable code not present)
https://github.com/dbry/WavPack/issues/26
https://github.com/dbry/WavPack/commit/8e3fe45a7bac31d9a3b558ae0079e2d92a04799e

Search for package or bug name: Reporting problems