CVE-2018-7286

NameCVE-2018-7286
DescriptionAn issue was discovered in Asterisk through 13.19.1, 14.x through 14.7.5, and 15.x through 15.2.1, and Certified Asterisk through 13.18-cert2. res_pjsip allows remote authenticated users to crash Asterisk (segmentation fault) by sending a number of SIP INVITE messages on a TCP or TLS connection and then suddenly closing the connection.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4320-1
NVD severitymedium
Debian Bugs891228

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
asterisk (PTS)stretch (security), stretch1:13.14.1~dfsg-2+deb9u4fixed
buster1:16.2.1~dfsg-1+deb10u2fixed
bullseye, sid1:16.16.1~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
asterisksourcewheezy(not affected)
asterisksourcejessie(not affected)
asterisksourcestretch1:13.14.1~dfsg-2+deb9u4DSA-4320-1
asterisksource(unstable)1:13.20.0~dfsg-1891228

Notes

[jessie] - asterisk <not-affected> (Vulnerable code not present)
[wheezy] - asterisk <not-affected> (Vulnerable code not present)
http://downloads.asterisk.org/pub/security/AST-2018-005.html
https://issues.asterisk.org/jira/browse/ASTERISK-27618
http://downloads.asterisk.org/pub/security/AST-2018-005-13.diff

Search for package or bug name: Reporting problems