CVE-2018-7420

NameCVE-2018-7420
DescriptionIn Wireshark 2.2.0 to 2.2.12 and 2.4.0 to 2.4.4, the pcapng file parser could crash. This was addressed in wiretap/pcapng.c by adding a block-size check for sysdig event blocks.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1353-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)jessie1.12.1+g01b65bf-4+deb8u14vulnerable
jessie (security)1.12.1+g01b65bf-4+deb8u15vulnerable
stretch (security), stretch2.6.3-1~deb9u1fixed
buster, sid2.6.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)2.4.5-1low
wiresharksourcewheezy1.12.1+g01b65bf-4+deb8u6~deb7u10mediumDLA-1353-1

Notes

[jessie] - wireshark <no-dsa> (Minor issue)
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=14403
https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=129e41f9f63885ad8224ef413c2860788fb9e849
https://www.wireshark.org/security/wnpa-sec-2018-11.html

Search for package or bug name: Reporting problems