CVE-2018-7551

NameCVE-2018-7551
DescriptionThere is an invalid free in MiniPS::delete0 in minips.cpp that leads to a Segmentation fault in sam2p 0.49.4. A crafted input will lead to a denial of service or possibly unspecified other impact.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1340-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sam2p (PTS)jessie0.49.2-3+deb8u2fixed
jessie (security)0.49.2-3+deb8u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sam2psource(unstable)(unfixed)high
sam2psourcejessie0.49.2-3+deb8u2high
sam2psourcewheezy0.49.1-1+deb7u3highDLA-1340-1

Notes

https://github.com/pts/sam2p/issues/28

Search for package or bug name: Reporting problems