CVE-2018-7588

NameCVE-2018-7588
DescriptionAn issue was discovered in CImg v.220. A heap-based buffer over-read in load_bmp in CImg.h occurs when loading a crafted bmp image.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1934-1
NVD severitymedium
Debian Bugs892780

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cimg (PTS)jessie1.5.9+dfsg-1vulnerable
jessie (security)1.5.9+dfsg-1+deb8u1fixed
stretch1.7.9+dfsg-1vulnerable
bullseye, sid, buster2.4.5+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cimgsource(unstable)2.3.6+dfsg-1low892780
cimgsourcejessie1.5.9+dfsg-1+deb8u1DLA-1934-1

Notes

[stretch] - cimg <no-dsa> (Minor issue)
[wheezy] - cimg <no-dsa> (Minor issue)
https://github.com/dtschump/CImg/issues/183
https://github.com/dtschump/CImg/commit/8447076ef22322a14a0ce130837e44c5ba8095f4

Search for package or bug name: Reporting problems