CVE-2018-7729

NameCVE-2018-7729
DescriptionAn issue was discovered in Exempi through 2.4.4. There is a stack-based buffer over-read in the PostScript_MetaHandler::ParsePSFile() function in XMPFiles/source/FileHandlers/PostScript_Handler.cpp.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs892782

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exempi (PTS)jessie2.2.1-2vulnerable
stretch2.4.1-1vulnerable
buster2.5.0-2fixed
bullseye, sid2.5.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exempisource(unstable)2.4.5-1low892782
exempisourcewheezy(not affected)

Notes

[stretch] - exempi <no-dsa> (Minor issue)
[jessie] - exempi <no-dsa> (Minor issue)
[wheezy] - exempi <not-affected> (vulnerable code not present)
https://bugs.freedesktop.org/show_bug.cgi?id=105206
https://cgit.freedesktop.org/exempi/commit/?id=baa4b8a02c1ffab9645d13f0bfb1c0d10d311a0c

Search for package or bug name: Reporting problems