CVE-2018-7875

NameCVE-2018-7875
DescriptionThere is a heap-based buffer over-read in the getString function of util/decompile.c in libming 0.4.8 for CONSTANT8 data. A Crafted input will lead to a denial of service attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1343-1
NVD severitymedium

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mingsourcewheezy1:0.4.4-1.1+deb7u8DLA-1343-1
mingsource(unstable)(unfixed)

Notes

https://github.com/libming/libming/issues/112

Search for package or bug name: Reporting problems