CVE-2018-8012

NameCVE-2018-8012
DescriptionNo authentication/authorization is enforced when a server attempts to join a quorum in Apache ZooKeeper before 3.4.10, and 3.5.0-alpha through 3.5.3-beta. As a result an arbitrary end point could join the cluster and begin propagating counterfeit changes to the leader.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4214-1
NVD severitymedium (attack range: remote)
Debian Bugs899332

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
zookeeper (PTS)jessie (security), jessie3.4.9-3+deb8u1fixed
stretch (security), stretch3.4.9-3+deb9u1fixed
buster, sid3.4.13-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zookeepersource(unstable)3.4.10-2medium899332
zookeepersourcejessie3.4.9-3+deb8u1mediumDSA-4214-1
zookeepersourcestretch3.4.9-3+deb9u1mediumDSA-4214-1

Notes

[wheezy] - zookeeper <ignored> (changes are too intrusive to backport)
https://issues.apache.org/jira/browse/ZOOKEEPER-1045
http://www.openwall.com/lists/oss-security/2018/05/21/6
https://cwiki.apache.org/confluence/display/ZOOKEEPER/Server-Server+mutual+authentication
https://issues.apache.org/jira/secure/attachment/12840904/ZOOKEEPER-1045-br-3-4.patch

Search for package or bug name: Reporting problems