CVE-2018-8022

NameCVE-2018-8022
DescriptionA carefully crafted invalid TLS handshake can cause Apache Traffic Server (ATS) to segfault. This affects version 6.2.2. To resolve this issue users running 6.2.2 should upgrade to 6.2.3 or later versions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
trafficserver (PTS)buster, buster (security)8.0.2+ds-1+deb10u3fixed
bullseye, sid8.1.0+ds-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
trafficserversource(unstable)7.0.0-1

Notes

https://www.openwall.com/lists/oss-security/2018/08/29/1
Only affects 6.x, marking 7.0 as the fixed version
https://github.com/apache/trafficserver/pull/2147

Search for package or bug name: Reporting problems