CVE-2018-8099

NameCVE-2018-8099
DescriptionIncorrect returning of an error code in the index.c:read_entry() function leads to a double free in libgit2 before v0.26.2, which allows an attacker to cause a denial of service via a crafted repository index file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2936-1
NVD severitymedium
Debian Bugs892962

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgit2 (PTS)stretch0.25.1+really0.24.6-1vulnerable
stretch (security)0.25.1+really0.24.6-1+deb9u1fixed
buster0.27.7+dfsg.1-0.2fixed
bullseye1.1.0+dfsg.1-4fixed
bookworm, sid1.3.0+dfsg.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgit2sourceexperimental0.27.0+dfsg.1-0.1
libgit2sourcestretch0.25.1+really0.24.6-1+deb9u1DLA-2936-1
libgit2source(unstable)0.27.0+dfsg.1-0.6low892962

Notes

[jessie] - libgit2 <no-dsa> (Minor issue)
https://github.com/libgit2/libgit2/commit/58a6fe94cb851f71214dbefac3f9bffee437d6fe

Search for package or bug name: Reporting problems