CVE-2018-8788

NameCVE-2018-8788
DescriptionFreeRDP prior to version 2.0.0-rc4 contains an Out-Of-Bounds Write of up to 4 bytes in function nsc_rle_decode() that results in a memory corruption and possibly even a remote code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freerdp (PTS)jessie (security), jessie1.1.0~git20140921.1.440916e+dfsg1-4+deb8u1vulnerable
stretch1.1.0~git20140921.1.440916e+dfsg1-13+deb9u2vulnerable
stretch (security)1.1.0~git20140921.1.440916e+dfsg1-13+deb9u1vulnerable
freerdp2 (PTS)buster, sid2.0.0~git20181120.1.e21b72c95+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freerdpsource(unstable)(unfixed)
freerdp2source(unstable)2.0.0~git20181120.1.e21b72c95+dfsg1-1

Notes

https://github.com/FreeRDP/FreeRDP/commit/d1112c279bd1a327e8e4d0b5f371458bf2579659

Search for package or bug name: Reporting problems