CVE-2018-8831

NameCVE-2018-8831
DescriptionA Persistent XSS vulnerability exists in Kodi (formerly XBMC) through 17.6 that allows the execution of arbitrary HTML/script code in the context of the victim user's browser via a playlist.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kodi (PTS)stretch2:17.1+dfsg1-3vulnerable
buster, sid2:17.6+dfsg1-4vulnerable
xbmc (PTS)jessie2:13.2+dfsg1-4vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kodisource(unstable)(unfixed)low
xbmcsource(unstable)(unfixed)medium

Notes

[stretch] - kodi <no-dsa> (Minor issue)
[jessie] - xbmc <no-dsa> (Minor issue)
[wheezy] - xbmc <no-dsa> (Minor issue)
http://seclists.org/fulldisclosure/2018/Apr/36
https://trac.kodi.tv/ticket/17814

Search for package or bug name: Reporting problems