CVE-2018-9058

NameCVE-2018-9058
DescriptionIn Long Range Zip (aka lrzip) 0.631, there is an infinite loop in the runzip_fd function of runzip.c. Remote attackers could leverage this vulnerability to cause a denial of service via a crafted lrz file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2725-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lrzip (PTS)stretch0.631-1vulnerable
stretch (security)0.631-1+deb9u3fixed
buster0.631+git180528-1fixed
buster (security)0.631+git180528-1+deb10u1fixed
bullseye0.641-1fixed
bullseye (security)0.641-1+deb11u1fixed
bookworm, sid0.651-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lrzipsourcestretch0.631-1+deb9u1DLA-2725-1
lrzipsource(unstable)0.631+git180517-1unimportant

Notes

https://github.com/ckolivas/lrzip/issues/93
No security impact

Search for package or bug name: Reporting problems