CVE-2018-9234

NameCVE-2018-9234
DescriptionGnuPG 2.2.4 and 2.2.5 does not enforce a configuration in which key certification requires an offline master Certify key, which results in apparently valid certifications that occurred only with access to a signing subkey.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs894983

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnupg2 (PTS)jessie (security), jessie2.0.26-6+deb8u2vulnerable
stretch2.1.18-8~deb9u4vulnerable
stretch (security)2.1.18-8~deb9u2vulnerable
buster2.2.12-1+deb10u1fixed
bullseye, sid2.2.17-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnupg2source(unstable)2.2.7-1low894983

Notes

[stretch] - gnupg2 <no-dsa> (Minor issue)
[jessie] - gnupg2 <no-dsa> (Minor issue)
[wheezy] - gnupg2 <no-dsa> (Minor issue)
https://dev.gnupg.org/T3844
https://git.gnupg.org/cgi-bin/gitweb.cgi?p=gnupg.git;a=commit;h=a17d2d1f690ebe5d005b4589a5fe378b6487c657

Search for package or bug name: Reporting problems