CVE-2018-9244

NameCVE-2018-9244
DescriptionGitLab Community and Enterprise Editions version 9.2 up to 10.4 are vulnerable to XSS because a lack of input validation in the milestones component leads to cross site scripting (specifically, data-milestone-id in the milestone dropdown feature). This is fixed in 10.6.3, 10.5.7, and 10.4.7.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs894868

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gitlab (PTS)sid/contrib13.4.7-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gitlabsourcestretch(not affected)
gitlabsource(unstable)10.6.3+dfsg-1894868

Notes

[stretch] - gitlab <not-affected> (Vulnerable code introduced in 9.2)
https://about.gitlab.com/2018/04/04/security-release-gitlab-10-dot-6-dot-3-released/

Search for package or bug name: Reporting problems