CVE-2018-9838

NameCVE-2018-9838
DescriptionThe caml_ba_deserialize function in byterun/bigarray.c in the standard library in OCaml 4.06.0 has an integer overflow which, in situations where marshalled data is accepted from an untrusted source, allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via a crafted object.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs895472

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ocaml (PTS)wheezy3.12.1-4vulnerable
wheezy (security)3.12.1-4+deb7u1vulnerable
jessie4.01.0-5vulnerable
stretch4.02.3-9vulnerable
buster, sid4.05.0-10vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ocamlsource(unstable)(unfixed)895472

Notes

[stretch] - ocaml <no-dsa> (Minor issue)
[jessie] - ocaml <no-dsa> (Minor issue)
https://caml.inria.fr/mantis/view.php?id=7765
https://github.com/ocaml/ocaml/pull/1718
https://github.com/ocaml/ocaml/commit/9664c7ee807c2dfa802f53cabd405ff58e219c47
Before 4.06.0+beta1 the code is present in otherlibs/bigarray/bigarray_stubs.c

Search for package or bug name: Reporting problems