CVE-2018-9918

NameCVE-2018-9918
Descriptionlibqpdf.a in QPDF through 8.0.2 mishandles certain "expected dictionary key but found non-name object" cases, allowing remote attackers to cause a denial of service (stack exhaustion), related to the QPDFObjectHandle and QPDF_Dictionary classes, because nesting in direct objects is not restricted.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs895443

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qpdf (PTS)jessie5.1.2-2vulnerable
stretch6.0.0-2vulnerable
buster, sid8.2.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qpdfsource(unstable)8.0.2-3medium895443

Notes

[stretch] - qpdf <no-dsa> (Minor issue)
[jessie] - qpdf <no-dsa> (Minor issue)
[wheezy] - qpdf <no-dsa> (Minor issue)
https://github.com/qpdf/qpdf/issues/202

Search for package or bug name: Reporting problems