CVE-2019-0155

NameCVE-2019-0155
DescriptionInsufficient access control in a subsystem for Intel (R) processor graphics in 6th, 7th, 8th and 9th Generation Intel(R) Core(TM) Processor Families; Intel(R) Pentium(R) Processor J, N, Silver and Gold Series; Intel(R) Celeron(R) Processor J, N, G3900 and G4900 Series; Intel(R) Atom(R) Processor A and E3900 Series; Intel(R) Xeon(R) Processor E3-1500 v5 and v6, E-2100 and E-2200 Processor Families; Intel(R) Graphics Driver for Windows before 26.20.100.6813 (DCH) or 26.20.100.6812 and before 21.20.x.5077 (aka15.45.5077), i915 Linux Driver for Intel(R) Processor Graphics before versions 5.4-rc7, 5.3.11, 4.19.84, 4.14.154, 4.9.201, 4.4.201 may allow an authenticated user to potentially enable escalation of privilege via local access.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1990-1, DSA-4564-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1fixed
jessie (security)3.16.76-1fixed
stretch4.9.189-3vulnerable
stretch (security)4.9.189-3+deb9u2fixed
buster4.19.67-2+deb10u1vulnerable
buster (security)4.19.67-2+deb10u2fixed
bullseye5.3.9-3fixed
sid5.3.15-1fixed
linux-4.9 (PTS)jessie (security)4.9.189-3+deb9u2~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)5.3.9-2
linuxsourcebuster4.19.67-2+deb10u2DSA-4564-1
linuxsourcejessie(not affected)
linuxsourcestretch4.9.189-3+deb9u2DSA-4564-1
linux-4.9sourcejessie4.9.189-3+deb9u2~deb8u1DLA-1990-1

Notes

[jessie] - linux <not-affected> (Driver doesn't support this hardware)

Search for package or bug name: Reporting problems