CVE-2019-0190

NameCVE-2019-0190
DescriptionA bug exists in the way mod_ssl handled client renegotiations. A remote attacker could send a carefully crafted request that would cause mod_ssl to enter a loop leading to a denial of service. This bug can be only triggered with Apache HTTP Server version 2.4.37 when using OpenSSL version 1.1.1 or later, due to an interaction in changes to handling of renegotiation attempts.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs920220

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)jessie2.4.10-10+deb8u12fixed
jessie (security)2.4.10-10+deb8u16fixed
stretch2.4.25-3+deb9u8fixed
stretch (security)2.4.25-3+deb9u9fixed
buster, buster (security)2.4.38-3+deb10u3fixed
bullseye, sid2.4.41-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2source(unstable)2.4.38-1920220
apache2sourcejessie(not affected)
apache2sourcestretch(not affected)

Notes

[stretch] - apache2 <not-affected> (Only affects 2.4.37)
[jessie] - apache2 <not-affected> (Only affects 2.4.37)
https://www.openwall.com/lists/oss-security/2019/01/22/4

Search for package or bug name: Reporting problems