CVE-2019-0217

NameCVE-2019-0217
DescriptionIn Apache HTTP Server 2.4 release 2.4.38 and prior, a race condition in mod_auth_digest when running in a threaded server could allow a user with valid credentials to authenticate using another username, bypassing configured access control restrictions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1748-1, DSA-4422-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)jessie2.4.10-10+deb8u12vulnerable
jessie (security)2.4.10-10+deb8u14fixed
stretch (security), stretch2.4.25-3+deb9u7fixed
buster, sid2.4.38-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2source(unstable)2.4.38-3medium
apache2sourcejessie2.4.10-10+deb8u14mediumDLA-1748-1
apache2sourcestretch2.4.25-3+deb9u7mediumDSA-4422-1

Notes

https://httpd.apache.org/security/vulnerabilities_24.html#CVE-2019-0217
https://svn.apache.org/r1855298

Search for package or bug name: Reporting problems