CVE-2019-0228

NameCVE-2019-0228
DescriptionApache PDFBox 2.0.14 does not properly initialize the XML parser, which allows context-dependent attackers to conduct XML External Entity (XXE) attacks via a crafted XFDF.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpdfbox-java (PTS)jessie1:1.8.7+dfsg-1+deb8u1fixed
jessie (security)1:1.8.7+dfsg-1+deb8u2fixed
stretch1:1.8.12-1fixed
bullseye, sid, buster1:1.8.16-2fixed
libpdfbox2-java (PTS)buster2.0.13-2fixed
bullseye, sid2.0.17-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpdfbox-javasource(unstable)(not affected)
libpdfbox2-javasource(unstable)(not affected)

Notes

- libpdfbox2-java <not-affected> (Vulnerable code introduced in 2.0.14)
- libpdfbox-java <not-affected> (Vulnerable code introduced in 2.0.14)
https://www.openwall.com/lists/oss-security/2019/04/12/1
https://issues.apache.org/jira/browse/PDFBOX-4505
Fixed by: https://svn.apache.org/r1856952 (2.0.15)

Search for package or bug name: Reporting problems