CVE-2019-10088

NameCVE-2019-10088
DescriptionA carefully crafted or corrupt zip file can cause an OOM in Apache Tika's RecursiveParserWrapper in versions 1.7-1.21. Users should upgrade to 1.22 or later.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs933744

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tika (PTS)jessie1.5-1fixed
buster1.20-1vulnerable
bullseye, sid1.22-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tikasource(unstable)1.22-1933744
tikasourcejessie(not affected)

Notes

[buster] - tika <no-dsa> (Minor issue)
[jessie] - tika <not-affected> (Vulnerable feature introduced in 1.7)
https://www.openwall.com/lists/oss-security/2019/08/02/2
https://github.com/apache/tika/commit/426be73b9e7500fa3d441231fa4e473de34743f6

Search for package or bug name: Reporting problems