CVE-2019-1010017

NameCVE-2019-1010017
Descriptionlibnmap < v0.6.3 is affected by: XML Injection. The impact is: Denial of service (DoS) by consuming resources. The component is: XML Parsing. The attack vector is: Specially crafted XML payload.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-libnmap (PTS)buster0.7.0-1vulnerable
bullseye, sid0.7.0-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-libnmapsource(unstable)(unfixed)low

Notes

[buster] - python-libnmap <no-dsa> (Minor issue)
https://github.com/savon-noir/python-libnmap/issues/87

Search for package or bug name: Reporting problems