CVE-2019-1010083

NameCVE-2019-1010083
DescriptionThe Pallets Project Flask before 1.0 is affected by: unexpected memory usage. The impact is: denial of service. The attack vector is: crafted encoded JSON data. The fixed version is: 1. NOTE: this may overlap CVE-2018-1000656.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
flask (PTS)jessie0.10.1-2vulnerable
jessie (security)0.10.1-2+deb8u1vulnerable
stretch0.12.1-1vulnerable
bullseye, sid, buster1.0.2-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
flasksource(unstable)1.0.2-1

Notes

[stretch] - flask <no-dsa> (Minor issue)
[jessie] - flask <no-dsa> (Minor issue)
https://www.palletsprojects.com/blog/flask-1-0-released/
https://github.com/pallets/flask/pull/2691/commits/ab4142215d836b0298fc47fa1e4b75408b9c37a0
After communication with MITRE, this CVE *might* overlap CVE-2018-1000656.
CVE-2019-1010083 was back then assigned by the DWF CNA, but the exact scope
of the CVE is unclear and might for instance be for an incomplete fix of
CVE-2018-1000656. As such it was only noted with a "may overlap". The
CVE-2019-1010083 only refers to the 1.0 release announcement and it is
guaranteed that it relates as well to pull request 2691. Upstream itself did
not comment on direct pings/questions back.

Search for package or bug name: Reporting problems