CVE-2019-1010174

NameCVE-2019-1010174
DescriptionCImg The CImg Library v.2.3.3 and earlier is affected by: command injection. The impact is: RCE. The component is: load_network() function. The attack vector is: Loading an image from a user-controllable url can lead to command injection, because no string sanitization is done on the url. The fixed version is: v.2.3.4.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1934-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cimg (PTS)jessie1.5.9+dfsg-1vulnerable
jessie (security)1.5.9+dfsg-1+deb8u1fixed
stretch1.7.9+dfsg-1vulnerable
bullseye, sid, buster2.4.5+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cimgsource(unstable)2.3.6+dfsg-1high
cimgsourcejessie1.5.9+dfsg-1+deb8u1highDLA-1934-1

Notes

https://framagit.org/dtschump/CImg/commit/5ce7a426b77f814973e56182a0e76a2b04904146 (v.2.3.4)

Search for package or bug name: Reporting problems