CVE-2019-1010190

NameCVE-2019-1010190
Descriptionmgetty prior to 1.2.1 is affected by: out-of-bounds read. The impact is: DoS, the program may crash if the memory is not mapped. The component is: putwhitespan() in g3/pbm2g3.c. The attack vector is: Local, the victim must open a specially crafted file. The fixed version is: 1.2.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mgetty (PTS)stretch (security), stretch1.1.36-3+deb9u1vulnerable
buster1.2.1-1fixed
bullseye1.2.1-1.1fixed
bookworm, sid1.2.1-1.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mgettysource(unstable)1.2.1-1

Notes

[stretch] - mgetty <no-dsa> (Minor issue)
[jessie] - mgetty <no-dsa> (Minor issue)
https://www.x41-dsec.de/lab/advisories/x41-2018-007-mgetty/

Search for package or bug name: Reporting problems