CVE-2019-1010228

NameCVE-2019-1010228
DescriptionOFFIS.de DCMTK 3.6.3 and below is affected by: Buffer Overflow. The impact is: Possible code execution and confirmed Denial of Service. The component is: DcmRLEDecoder::decompress() (file dcrledec.h, line 122). The attack vector is: Many scenarios of DICOM file processing (e.g. DICOM to image conversion). The fixed version is: 3.6.4, after commit 40917614e.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dcmtk (PTS)buster3.6.4-2.1fixed
bullseye3.6.5-1fixed
bookworm3.6.7-8fixed
trixie3.6.7-9fixed
sid3.6.7-13fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dcmtksource(unstable)3.6.4-1low

Notes

[stretch] - dcmtk <no-dsa> (Minor issue)
[jessie] - dcmtk <no-dsa> (Minor issue)
https://support.dcmtk.org/redmine/issues/858
https://github.com/commontk/DCMTK/commit/40917614e

Search for package or bug name: Reporting problems