CVE-2019-1010238

NameCVE-2019-1010238
DescriptionGnome Pango 1.42 and later is affected by: Buffer Overflow. The impact is: The heap based buffer overflow can be used to get code execution. The component is: function name: pango_log2vis_get_embedding_levels, assignment of nchars and the loop condition. The attack vector is: Bug can be used when application pass invalid utf-8 strings to functions like pango_itemize.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4496-1
NVD severityhigh (attack range: remote)
Debian Bugs933860

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pango1.0 (PTS)jessie1.36.8-3fixed
stretch1.40.5-1fixed
buster1.42.4-6vulnerable
buster (security)1.42.4-7~deb10u1fixed
bullseye, sid1.42.4-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pango1.0source(unstable)1.42.4-7high933860
pango1.0sourcebuster1.42.4-7~deb10u1highDSA-4496-1
pango1.0sourcejessie(not affected)
pango1.0sourcestretch(not affected)

Notes

[stretch] - pango1.0 <not-affected> (Vulnerable code introduced later)
[jessie] - pango1.0 <not-affected> (Vulnerable code introduced later)
https://gitlab.gnome.org/GNOME/pango/issues/342
https://gitlab.gnome.org/GNOME/pango/commit/490f8979a260c16b1df055eab386345da18a2d54 (1.44)

Search for package or bug name: Reporting problems