CVE-2019-1010266

NameCVE-2019-1010266
Descriptionlodash prior to 4.17.11 is affected by: CWE-400: Uncontrolled Resource Consumption. The impact is: Denial of service. The component is: Date handler. The attack vector is: Attacker provides very long strings, which the library attempts to match using a regular expression. The fixed version is: 4.17.11.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-lodash (PTS)jessie2.4.1+dfsg-3vulnerable
stretch4.16.6+dfsg-2vulnerable
buster4.17.11+dfsg-2+deb10u1fixed
bullseye, sid4.17.15+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-lodashsource(unstable)4.17.11+dfsg-1unimportant

Notes

https://github.com/lodash/lodash/issues/3359
https://snyk.io/vuln/SNYK-JS-LODASH-73639
nodejs not covered by security support

Search for package or bug name: Reporting problems