CVE-2019-1010317

NameCVE-2019-1010317
DescriptionWavPack 5.1.0 and earlier is affected by: CWE-457: Use of Uninitialized Variable. The impact is: Unexpected control flow, crashes, and segfaults. The component is: ParseCaffHeaderConfig (caff.c:486). The attack vector is: Maliciously crafted .wav file. The fixed version is: After commit https://github.com/dbry/WavPack/commit/f68a9555b548306c5b1ee45199ccdc4a16a6101b.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs932060

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wavpack (PTS)stretch (security), stretch5.0.0-2+deb9u2vulnerable
buster5.1.0-6vulnerable
bullseye, sid5.3.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wavpacksource(unstable)5.1.0-7low932060

Notes

[buster] - wavpack <no-dsa> (Minor issue)
[stretch] - wavpack <no-dsa> (Minor issue)
[jessie] - wavpack <no-dsa> (Minor issue)
https://github.com/dbry/WavPack/commit/f68a9555b548306c5b1ee45199ccdc4a16a6101b
https://github.com/dbry/WavPack/issues/66

Search for package or bug name: Reporting problems