CVE-2019-10143

NameCVE-2019-10143
Description** DISPUTED ** It was discovered freeradius up to and including version 3.0.19 does not correctly configure logrotate, allowing a local attacker who already has control of the radiusd user to escalate his privileges to root, by tricking logrotate into writing a radiusd-writable file to a directory normally inaccessible by the radiusd user. NOTE: the upstream software maintainer has stated "there is simply no way for anyone to gain privileges through this alleged issue."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: local)
Debian Bugs929466

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freeradius (PTS)jessie (security), jessie2.2.5+dfsg-0.2+deb8u1vulnerable
stretch (security), stretch3.0.12+dfsg-5+deb9u1vulnerable
buster3.0.17+dfsg-1.1vulnerable
bullseye, sid3.0.19+dfsg-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freeradiussource(unstable)(unfixed)unimportant929466

Notes

https://github.com/FreeRADIUS/freeradius-server/pull/2666
https://github.com/FreeRADIUS/freeradius-server/commit/1f233773962bf1a9c2d228a180eacddb9db2d574
This is not a security issue per se

Search for package or bug name: Reporting problems