CVE-2019-10145

NameCVE-2019-10145
Descriptionrkt through version 1.30.0 does not isolate processes in containers that are run with `rkt enter`. Processes run with `rkt enter` do not have seccomp filtering during stage 2 (the actual environment in which the applications run). Compromised containers could exploit this flaw to access host resources.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: local)
Debian Bugs929781

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rkt (PTS)sid1.30.0+dfsg-7vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rktsource(unstable)(unfixed)medium929781

Notes

https://www.twistlock.com/labs-blog/breaking-out-of-coresos-rkt-3-new-cves/
https://github.com/rkt/rkt/issues/3998

Search for package or bug name: Reporting problems