CVE-2019-10162

NameCVE-2019-10162
DescriptionA vulnerability has been found in PowerDNS Authoritative Server before versions 4.1.10, 4.0.8 allowing an authorized user to cause the server to exit by inserting a crafted record in a MASTER type zone under their control. The issue is due to the fact that the Authoritative Server will exit when it runs into a parsing error while looking up the NS/A/AAAA records it is about to use for an outgoing notify.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1843-1, DSA-4470-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pdns (PTS)jessie3.4.1-4+deb8u8vulnerable
jessie (security)3.4.1-4+deb8u10fixed
stretch (security), stretch4.0.3-1+deb9u5fixed
buster4.1.6-3fixed
bullseye, sid4.2.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pdnssource(unstable)4.1.6-3
pdnssourcejessie3.4.1-4+deb8u10DLA-1843-1
pdnssourcestretch4.0.3-1+deb9u5DSA-4470-1

Notes

https://www.openwall.com/lists/oss-security/2019/06/21/5
https://doc.powerdns.com/authoritative/security-advisories/powerdns-advisory-2019-04.html

Search for package or bug name: Reporting problems