CVE-2019-10173

NameCVE-2019-10173
DescriptionIt was found that xstream API version 1.4.10 before 1.4.11 introduced a regression for a previous deserialization flaw. If the security framework has not been initialized, it may allow a remote attacker to run arbitrary shell commands when unmarshalling XML or any supported format. e.g. JSON. (regression of CVE-2013-7285)
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxstream-java (PTS)buster1.4.11.1-1+deb10u3fixed
buster (security)1.4.11.1-1+deb10u4fixed
bullseye1.4.15-3+deb11u1fixed
bullseye (security)1.4.15-3+deb11u2fixed
bookworm, sid1.4.20-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxstream-javasourcejessie(not affected)
libxstream-javasourcestretch(not affected)
libxstream-javasource(unstable)1.4.11-1

Notes

[stretch] - libxstream-java <not-affected> (Regression introduced in 1.4.10)
[jessie] - libxstream-java <not-affected> (Regression introduced in 1.4.10)
http://x-stream.github.io/changes.html#1.4.11
Regression introduced and present only in 1.4.10.

Search for package or bug name: Reporting problems