CVE-2019-10182

NameCVE-2019-10182
DescriptionIt was found that icedtea-web though 1.7.2 and 1.8.2 did not properly sanitize paths from <jar/> elements in JNLP files. An attacker could trick a victim into running a specially crafted application and use this flaw to upload arbitrary files to arbitrary locations in the context of the user.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs934319

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedtea-web (PTS)jessie1.5.3-1vulnerable
stretch1.6.2-3.1+deb9u1vulnerable
buster1.7.2-2vulnerable
bullseye, sid1.8.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icedtea-websource(unstable)1.8.3-1medium934319

Notes

https://www.openwall.com/lists/oss-security/2019/07/31/2
https://github.com/AdoptOpenJDK/IcedTea-Web/pull/344

Search for package or bug name: Reporting problems