CVE-2019-10191

NameCVE-2019-10191
DescriptionA vulnerability was discovered in DNS resolver of knot resolver before version 4.1.0 which allows remote attackers to downgrade DNSSEC-secure domains to DNSSEC-insecure state, opening possibility of domain hijack using attacks against insecure DNS protocol.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs932048

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
knot-resolver (PTS)buster, bullseye, sid3.2.1-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
knot-resolversource(unstable)(unfixed)medium932048

Notes

https://www.knot-resolver.cz/2019-07-10-knot-resolver-4.1.0.html
https://gitlab.labs.nic.cz/knot/knot-resolver/merge_requests/839
https://www.openwall.com/lists/oss-security/2019/07/14/1

Search for package or bug name: Reporting problems