CVE-2019-10197

NameCVE-2019-10197
DescriptionA flaw was found in samba versions 4.9.x up to 4.9.13, samba 4.10.x up to 4.10.8 and samba 4.11.x up to 4.11.0rc3, when certain parameters were set in the samba configuration file. An unauthenticated attacker could use this flaw to escape the shared directory and access the contents of directories outside the share.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4513-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)stretch2:4.5.16+dfsg-1+deb9u2fixed
stretch (security)2:4.5.16+dfsg-1+deb9u4fixed
buster, buster (security)2:4.9.5+dfsg-5+deb10u3fixed
bullseye (security), bullseye2:4.13.13+dfsg-1~deb11u3fixed
bookworm, sid2:4.16.1+dfsg-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasourcejessie(not affected)
sambasourcestretch(not affected)
sambasourcebuster2:4.9.5+dfsg-5+deb10u1DSA-4513-1
sambasource(unstable)2:4.9.13+dfsg-1

Notes

[stretch] - samba <not-affected> (Issue introduced in 4.9.0 upstream)
[jessie] - samba <not-affected> (Issue introduced in 4.9.0 upstream)
https://www.samba.org/samba/security/CVE-2019-10197.html

Search for package or bug name: Reporting problems