CVE-2019-1020014

NameCVE-2019-1020014
Descriptiondocker-credential-helpers before 0.6.3 has a double free in the List functions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow
Debian Bugs933801

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
golang-github-docker-docker-credential-helpers (PTS)stretch0.3.0+git20160601.0.5128fa1-1vulnerable
buster0.6.1-2vulnerable
bullseye, sid0.6.1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
golang-github-docker-docker-credential-helperssource(unstable)0.6.1-3933801

Notes

[buster] - golang-github-docker-docker-credential-helpers <no-dsa> (Minor issue, can be fixed in point release)
https://github.com/docker/docker-credential-helpers/commit/1c9f7ede70a5ab9851f4c9cb37d317fd89cd318a

Search for package or bug name: Reporting problems