CVE-2019-10203

NameCVE-2019-10203
DescriptionPowerDNS Authoritative daemon , pdns versions 4.0.x before 4.0.9, 4.1.x before 4.1.11, exiting when encountering a serial between 2^31 and 2^32-1 while trying to notify a slave leads to DoS.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs970729

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pdns (PTS)stretch, stretch (security)4.0.3-1+deb9u5vulnerable
buster4.1.6-3+deb10u1fixed
bullseye4.4.1-1fixed
bookworm, sid4.6.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pdnssourcebuster4.1.6-3+deb10u1
pdnssource(unstable)4.2.0-1low970729

Notes

[stretch] - pdns <no-dsa> (Minor issue)
[jessie] - pdns <no-dsa> (Minor issue)
Fixed in 4.2.0, 4.1.11, 4.0.9, for existing installations a manual schema update
needs to be performed.
https://doc.powerdns.com/authoritative/security-advisories/powerdns-advisory-2019-06.html

Search for package or bug name: Reporting problems