CVE-2019-10206

NameCVE-2019-10206
Descriptionansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain special characters. Passwords should be wrapped to prevent templates trigger and exposing them.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs933005

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ansible (PTS)stretch (security), stretch2.2.1.0-2+deb9u1vulnerable
buster2.7.7+dfsg-1vulnerable
bullseye, sid2.9.13+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ansiblesourcejessie(not affected)
ansiblesource(unstable)2.8.6+dfsg-1933005

Notes

[buster] - ansible <no-dsa> (Minor issue)
[stretch] - ansible <no-dsa> (Minor issue)
[jessie] - ansible <not-affected> (Vulnerable code introduced later, password templating code introduced with 2.0 refactoring, '{{' supported in passwords)
https://github.com/ansible/ansible/pull/59246
2.8.x https://github.com/ansible/ansible/pull/59552
2.7.x https://github.com/ansible/ansible/pull/59553
2.6.x https://github.com/ansible/ansible/pull/59554
When fixing this issue is needed to make the fix complete with
https://github.com/ansible/ansible/pull/63351 to not open
CVE-2019-14856.

Search for package or bug name: Reporting problems